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Objective 
To demonstrate and practice step-by-step on the modeling, static analysis 
and design of 5 story reinforced concrete building. 

Problem 
Part A: 

Carry out the modeling, static analysis and design of 5 story reinforced 
concrete building subjected to static loads.  

Part B: 

Use the model from part A to analyze and design for dynamic load 
(UBC97 response spectrum load in Y direction). 

Part C: 

Model, analyze and design Shear Wall. 

 Material Properties 
Strength of concrete (Fc’)    =         4 ksi 
Yield strength of main reinforcement (Fy)   =       60 ksi 
Yield strength of shear reinforcement (Fys) =       60 ksi 
Young Modulus of concrete          ( Ec) =   3600 ksi 

 
Loading 

Load Cases Type Details 

DEAD Dead load Use Self Weight Multiplier 

SUPERDL Dead load Slabs: 35 psf 
Perimeter Beams: 250 plf 

LIVE Live load Slab: 100 psf 

SPEC1 (for Part B) Dynamic load 
UBC97 response spectrum 
in Y direction 
Ca = 0.1, Cv = 0.1 

 
Slab Section 

Reinforced concrete solid slab, thickness = 6 inch 

Frame Sections 

20"

20"

12"

24"

Colum n
(C1)

Beam
(B1)  
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3D View of the building 

 

Plan and Elevation View 
Plan View at Roof Foor 
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 Elevation At Grid Lines 2, 3, 4, A, B and C (Shear Wall Not Shown) 
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Part A: Modeling, Static Analysis and Design 
Step-by-Step Solution 

1. Define Plan Grids and Story Data 

 
Step 1-1: Start ETABS by clicking on the appropriate desktop shortcut or by selecting 
ETABS from your Windows Start menu. Select “Kip-in” from drop-down menu box in bot-
tom-right screen and click on  in top tool bar or go to File > New Model in main menu. 
Click No to start new model without opening any existing file. 

 

 Click the Default.edb button. This means that the definitions and preferences will be 
initialized (get their initial values) from the Default.edb file that is in the same directory 
as your ETABS.exe file. If the Default.edb file does not exist in this directory then the 
definitions and preferences are initialized using ETABS built-in defaults. 

You should create your Default.edb file such that you most commonly click this but-
ton. 

 In some cases you may want to click the Choose .edb button and specify a different 
file from which the definitions and preferences are to be initialized. For example, a cer-
tain client or project may require certain things in your model to be done in a certain 
way that is different from your typical office standards. You could have a specific .edb 
file set up for this client or project which could then be used to initialize all models for 
the client or project. 

Click the No button if you just want to use the built-in ETABS defaults. 
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Step 1-2: Enter “240” or “20 ft” into Spacing in X Direction and Spacing in Y Direction, 
“5” into Number of Stores, select Grid Only from Add Structural Objects and click OK. 

 
 
 

 
Step 1-3: After clicking OK, ETABS creates Grid System based on the parameters 
specified in the previous step and displays in “Plan View” and “3-D View” window. 
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Step 1-4: Save the project by clicking on  or File > Save from main menu, 
enter File name = "ETABS_ex01" and click Save.  

 

2. Define Material Properties 
Default concrete material (“CONC”) has been used for this example. 

Strength of concrete (Fc’)    =         4 ksi 
Yield strength of main reinforcement (Fy)   =       60 ksi 
Yield strength of shear reinforcement (Fys) =       60 ksi 
Young Modulus of concrete          ( Ec) =   3600 ksi 

 

 
Step 2-1: Click on  in tool bar or from Define > Material Properties in main 
menu. Select CONC and click on Modify/Show Material to view/revise the 
material properties.  
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Step 2-2: Accept the default properties by clicking Cancel or OK 2 times  
 

3. Define Frame Sections 
2 concrete frame sections (“B1” for rectangular beams and “C1” for cir-
cle columns) need to be defined for this example. 

20"

20"

12"

24"

Colum n
(C1)

Beam
(B1)  

  

Step 3-1: Click on  in tool bar or from Define > Frame Sections in main 
menu to start frame section definition properties editor. Select “Add Rectan-
gular” from second drop-down menu to add rectangular beam. 
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Reinforcing Information for Beams 
For concrete beams there are two types of reinforcing information that you 
specify. They are rebar cover and reinforcement overrides. Rebar cover is 
specified at the top and bottom of the beam. The top cover is measured 
from the top of the beam to the centroid of the top longitudinal reinforcing. 
The bottom cover is measured from the bottom of the beam to the centroid 
of the bottom longitudinal reinforcing. 

The reinforcement overrides are specified areas of longitudinal reinforcing 
steel that occur at the top and bottom of the left and right ends of the beam. 
These overrides are used by ETABS as follows: 

In the Concrete Frame Design postprocessor when the design shear in a concrete 
beam is to be based on provided longitudinal reinforcement (that is, the shear de-
sign is based on the moment capacity of the beam) ETABS compares the calcu-
lated required reinforcement with that specified in the reinforcement overrides and 
uses the larger value to determine the moment capacity on which the shear design 
is based. 

In the Concrete Frame Design postprocessor when the minimum reinforcing in the 
middle of a beam is to be based on some percentage of the reinforcing at the ends 
of the beam ETABS compares the calculated required reinforcement at the ends of 
the beam with that specified in the reinforcement overrides and uses the larger 
value to determine the minimum reinforcing in the middle of the beam. 

In the Concrete Frame Design postprocessor when the shear design of columns is 
to be based on the maximum moment that the beams can deliver to the columns 
ETABS compares the calculated required reinforcement with that specified in the 
reinforcement overrides and uses the larger value to determine the moment capac-
ity of the beam. 

For any degree of freedom in the frame nonlinear hinge properties assigned to a 
concrete member that is specified as default ETABS calculates the hinge force-
deformation properties based on the larger of the calculated required reinforcement 
at the ends of the beam (assuming you have run the design through the Concrete 
Frame Design postprocessor) and the specified reinforcement overrides. 
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Step 3-2: Enter “B1” as Section Name as shown in the above figure and accept the 
other data. Click on Reinforcement to specify reinforcement data.  

 
 

 

Step 3-3: Select Design Type = “Beam” and click OK 2 times to go back to “Define 
Frame Properties” window. 

 



ETABS Tutorial Example 
  

Static, Dynamic Analysis and Design of Building with Shear Wall 13/ 58 

 

Step 3-4: The “Define Frame Properties” window shows “B1” section added in the 
list. Select “Add Circle” from second drop-down menu to add column section. 

Reinforcing Information for Columns 
For columns the following areas are provided in the Reinforcement Data 
dialog box: 

Configuration of Reinforcement: Here you can specify rectangular or circular re-
inforcement. You can if desired put circular reinforcement in a rectangular beam or 
put rectangular reinforcement in a circular beam. 

Lateral Reinforcement: If you have specified a rectangular configuration of rein-
forcement then the only choice available to you here is ties. If you have specified a 
circular configuration of reinforcement then you have an option of either ties or spi-
ral for the lateral (transverse) reinforcement. 

Rectangular Reinforcement: This area is visible if you have chosen a rectangular 
configuration of reinforcement. The following options are available in this area. 

Cover to Rebar Center: This is the distance from the edge of the column to the 
center of a longitudinal bar. In the special case of rectangular reinforcement in a 
circular column the cover is taken to be the minimum distance from the edge of the 
column to the center of a corner bar of the rectangular reinforcement pattern. 

Number of bars in 3-dir: This is the number of longitudinal reinforcing bars (in-
cluding corner rebar) on the two faces of the column that are parallel to the local 3-
axis of the section. 

Number of bars in 2-dir: This is the number of longitudinal reinforcing bars (in-
cluding corner rebar) on the two faces of the column that are parallel to the local 2-
axis of the section. 

Bar size: This is the specified size of reinforcing steel for the section. You can only 
specify one bar size for a given concrete frame section property. 

Circular Reinforcement: This area is visible if you have chosen a circular configu-
ration of reinforcement. The following options are available in this area. 

Cover to Rebar Center: This is the distance from the edge of the column to the 
center of a longitudinal bar. In the special case of circular reinforcement in a rec-
tangular column the cover is taken to be the minimum distance from the edge of 



ETABS Tutorial Example ACECOMS, AIT  
 

Static, Dynamic Analysis and Design of Building with Shear Wall 14/ 58 

the column to a circle drawn through the center of all the rebar in the circular rein-
forcement pattern. 

Number of bars: This is the number of longitudinal reinforcing bars in the section. 

Bar size: This is the specified size of reinforcing steel for the section. You can only 
specify one bar size for a given concrete frame section property. 

Check/Design: In this area you specify that when a member with this frame sec-
tion property is run through the Concrete Frame Design postprocessor the rein-
forcement is either to be checked or to be designed. If the reinforcement is to be 
checked then all information in the Reinforcement Data dialog box is used. If the 
reinforcement is to be designed then all information in the Reinforcement Data dia-
log box is used except the bar size is ignored and the total required steel area is 
calculated. For design the configuration of reinforcement, lateral reinforcement and 
cover is used. 

If you specify reinforcing in a concrete column frame section property that is 
specified using the section designer utility then the Concrete Frame Design 
postprocessor either checks the column for the specified reinforcing or de-
signs new reinforcing depending on the option you selected when you 
specified the section. 

 

 
Step 3-5: Enter “C1” section properties as shown in above figure, accept other data 
and click on Reinforcement button to specify reinforcement data. 
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Step 3-6: In Design Type area select Design Type = “Column”. Clicking OK 2 
times to finish this step. 

 
 
 

 
 

Step 3-7: Define Frame Properties dialogue shows “C1” section in list. Click OK to 
go back to main screen, which completes the Frame Section Definition steps. 
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4. Define Slab Sections 
Default slab section (“SLAB1”) will be modified by changing only the 
thickness value. 

 
Step 4-1: Click on  in tool bar or Define > Wall/Slab/Deck Sections menu 
command. Select “SLAB1” from list and click on Modify/Show Section. 

 

 
Step 4-2: Specify Thickness = “6” in Membrane and Bending and click OK 2 
times to finish Define Slab Section. 

 
Thickness: Two thicknesses are specified: membrane and bending. Typi-
cally these thicknesses are the same but they can be different. For instance 
they may be different if you are trying to model full shell behavior for a cor-
rugated metal deck. 

The membrane thickness is used for calculating: 

 The membrane stiffness for full shell and pure membrane sections. 

 The element volume for element self-mass and self-weight calculations. 

The bending thickness is used for calculating the plate-bending and trans-
verse-shearing stiffnesses for full shell and pure plate sections. 
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5. Define Load Cases 
2 basic load cases “DEAD”, “LIVE” will be defined first and one more 
load cases (“SUPERDL”) will be defined for superimposed dead load on 
perimeter beams. 

 
Step 5-1: Click on  in tool bar or select Define > Load Cases menu. 2 basic load 
cases are already added to the list.  
 
Add “SUPERDL” load case by entering "Load" = "SUPERDL", "Type" = "SUPER 
DEAD" and "Self Weight Multiplier" = "0". Click Add New Load and click OK to fin-
ish this step. 

6. Draw Beam Objects (Frame Members) 
Select “Similar Stories” from drop-down menu in bottom-right of screen to 
apply all assignments in one floor (current floor) in ‘Plan View” to all similar 
stories. Similar floor can be defined from Edit > Edit Story Data > Edit 
Story menu 

 

Step 6-1: Back to main screen, activate “Plan View” window by clicking anywhere in 
left window. Change “One Story” to “Similar Stories” from drop-down menu in bot-
tom-right screen (to edit multiple stories simultaneously). 
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Step 6-2: Click on  in tool bar. “The properties of Object” window will ap-
pear. Select Property = “B1”. 

 
 
 

 
Step 6-3: To add “B1” in all spans in model, draw rectangular selection to cover all 
plan in Plan View. “B1” will be added in every span of the entire model. 
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Step 6-4: Change back to selection mode by clicking on  in tool bar. To delete 
all beams in top-right corner, click on these 2 bays, the selection status in bottom-
left of main screen reports “10 Lines selected” (2 bays x 5 floors). If this report is 
different, press  and repeat this step again. Press Delete key on keyboard.  

 
 
 

7. Draw Column Objects (Frame Members) 
The procedure for adding column is similar to adding beams as described 
in previous section. Make sure that “Similar Stories” is selected from drop-
down menu in bottom-right of main screen. 

 

 

Step 7-1: Click on  in left tool bar. Select Property = “C1” from “Properties of 
Object” window. 
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Step 7-2: To add “C1” in all column locations in the model, draw rectangular selec-
tion to cover all plan in the Plan View. Note the change in 3D view. 

 
 
 
 

 

Step 7-3: Change back to selection mode by clicking on  in left tool bar. Make 

sure that “Snap to Grid Intersections and Points” is active . Click on intersection 
point between grid line D and 4 while holding Ctrl on the keyboard. 
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Step 7-4: “Selection List” window will open showing that points and a columns ob-
ject are in the same location. Click on  “COLUMN” to select only the columns. “5 
Lines Selected” (1 column line x 5 floors) message is displayed on the status bar at 
bottom-left of screen. Press Delete key on keyboard or go to select Edit > Delete 
menu to delete the selected columns. 

 

8. Assign Slab Sections  
Slab section will be assigned to all floors in “Plan View” window in one 
step by taking advantage of “Similar Stories” feature. 

 
Step 8-1: Click on  in tool bar or select Draw > Draw Areas Objects > 
Draw Areas menu Select Property = “SLAB1” from Properties of Object 
window. 
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Step 8-2: Make sure that “Snap to Grid Intersections and Points” is active . To 
draw Slab Object, one click a series of column locations as shown above and dou-
ble click on the column to finish the operation. 

 
 
 
 

 
Step 8-3: Slab sections are applied in all floors. To view slab more clearly, click on 

 or go to View > Set Building View Options, select “Object Fill” to fill area ob-
jects and select “Apply to All Windows” to applied selected options to all windows. 
Click OK. 

 

Double click 
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Step 8-4: Click on , select all Slabs by clicking on them go to Assign >> 
Shell/Area >> Area Object Mesh Options and specify parameter as shown in 
above figure 

 

9. Assign Restrains 
All nodes at Basement Floor will be assigned to be Hinge automatically. To 
change support restraint properties, select support nodes, click on  or go 
to Assign > Joint/Point > Restraint menu and select support type. 

 
Step 9-1: Change Elevation View to Plan View by clicking  and selecting “BASE” 
from list. Click on tight button of the mouse at any joints on this Plan View to open 
“Point Information” window. 
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Step 9-2: Click on “Assignments” tab. In “Restraint” shows “ux, uy, uz” that means 
all deformation in x, y and z direction are fixed. Click Cancel. 

 

10. Assign Slab Loads 
Self weight for slabs and beams are computed automatically which can be 
specified while defining load cases and setting "Self Weight Multiplier" = "1" 
for "DEAD" load case"  (see Step 5-1). Live load (100 psf) will be assigned 
in "LIVE" load case. Wall load along perimeter beams (250 plf) and super-
imposed dead load (35 psf) in slabs will be assigned to "SUPERDL" load 
case. All steps will be done in Plan View keeping "Similar Stories" selected. 

 

 
Step 10-1: Change “Elevation View” to “Plan View” by clicking  and selecting 
“STORY5” from list. Select "Similar Stories" in drop-down menu in bottom-right of 
screen. 
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Step 10-2: Click any area in slab from Plan View. The status bar shows "5 Areas, 
30 Edges selected" (1 areas x 5 floors). Click on  or select Assign > Shell/Area 
Loads > Uniform menu. In "Uniform Surface Loads" window, select Load Case 
Name = "LIVE", select Unit = "lb-ft", select Direction = "Gravity", enter Load = 
"100" (positive for downward in "Gravity" direction) and click OK. 

 

 
Step 10-3: Repeat Step 10-1and Step 10-2 to assign “35 psf” to "SUPERDL" load 
case in all slabs. 

 

 
Step 10-4: Click on  or go to Draw > Snap to > Lines and Edges. Move mouse 
over perimeter beam wait until red dot appears on that beam then right mouse click. 
Repeat this step to select perimeter beam one by one until bottom-left screen dis-
plays "60 Lines selected" (12 bays x 5 floors). 
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Step 10-5: Click on  or select Assign > Frame/Line Loads > Distributed. Menu 
to specify Load Case Name = "SUPERDL", Units = "lb-ft" and Uniform Load = 
"250" and click OK. 

 

 
Step 10-6: To display distributed load that just assigned in perimeter beams from 
previous step. Activate "3D View" window, select Display > Show Loads > 
Frame/Line menu, select Load case = "SUPERDL" and click OK. Click on  to 
change back to normal display mode. 
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11. View Input Data in Tabular Form 

 
Step 11-1: Go to Display > Set Input Table Mode, select items to be displayed 
and click OK. 

 
 
 
 

 
Step 11-2: To view each input data, select items from drop-down menu. Click OK to 
finish this step. 
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12. Run the Analysis 
 

 
 

Step 12-1: Go to Analysis > Set Analysis Options, select "Full 3D", deselect "Dy-
namic Analysis" (not required for this part of example) and click OK. 

 
 
 
 
 
 
 

 
 

Step 12-2: Click on  or go to Analysis > Run Analysis, click on Run from Analy-
sis Options "Window" and wait until ETABS displays "ANALYSIS COMPLETE" and 
click OK. 
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Step 12-3: When Analysis process has been completed, ETABS will display de-
formed shape of the model in active window and model is locked automatically (  
is pressed). When the model is locked, model cannot be modified unless unlock the 
model by depressing  button. After model is unlocked, all output data will be de-
leted and reanalysis is required to obtain output data again. 

 
 

13. View Analysis Results Graphically 
 

 

Step 13-1: Deformed shape can be displayed by clicking on  and select load 
case from drop-down menu. 
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Step 13-2: Deformed shape can be displayed in animation by clicking on Start 
Animation. Speed can be adjusted by scroll bar at the bottom of this window. Click 
on Stop Animation and click on  to change back to normal display mode. 

 
 
 
 
 
 

 
Step 13-3: Active "Plan View" window and change to "Elevation View" by clicking 
on  and selecting Elevation = "1". 
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Step 13-4: Analysis results can be displayed by clicking on . Select load cases 
from drop-down menu, select "Component" (shear, moment or torsion) and select 
"Fill Diagram". 

 
 
 
 

 
Step 13-5: Now moment diagrams  (3-3) are displayed with positive moment on the 
tension side. To display tension in negative side, go to Options and deselect Mo-
ment Diagrams on Tension Side. Right click on the beam between grid line A and 
B at roof floor to display analysis result details. 
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Step 13-6: Loads, shears, moments and deflections for the right clicked beam are 
displayed. Select Display Options = "Show Max" to see maximum and location for 
each result. Select Display Options = "Scroll for Values" result values at particular 
location can be shown by moving scroll bar or entering location in text box. Click 
Done to close this window and click on  to change back to normal display mode.. 

 

14. Design Concrete Frame Elements 
There are many design codes available for concrete frame design. ETABS 
will define load combinations according to specified design code automati-
cally after specifying the design codes. Additional load combinations can be 
defined and added to the design combo list if required. 

 

 
 

Step 14-1: To select design code, go to Options > Preferences > Concrete Frame 
Design menu, select "ACI 318-89" and click OK. 
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Step 14-2: To see load combination for design, go to Design > Concrete Frame 
Design > Design Combo. 2 load combinations are defined and selected for design 
automatically, select "DCON2" and click Show. Load factors are defined according 
to specified design code from previous step. Click OK 2 times. 

 

 
Step 14-3: Start concrete frame design by clicking on . When ETABS finishes 
the design process, required reinforcement in each element will be displayed.  

 

 
Step 14-4: To see beam design details, right mouse click on particular beam (ex-
ample beam between grid line A and B at roof floor). ETABS highlights the critical 
location along the element length (maximum required reinforcement). More details 
can be displayed by clicking on button below. Click OK to close this dialogue. 
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Step 14-5: As beam design details, column design details can be displayed by right 
mouse clicking on particular column (example column along grid line A between 
roof and 4 floor). ETABS highlights the critical location along element length (maxi-
mum required reinforcement). More design details can be displayed by clicking on 
button below. Click OK to close this dialogue. 

 
 

 
 

Step 14-6: To display design input or output in graphic view, go to Design > Con-
crete Frame Design > Display Design Results. 

 
 

 

Step 14-7: To display the status on the concrete frame embers that passed the de-
sign, go to Design > Concrete Frame Design > Verify Analysis VS Design Sec-
tion. 
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Part B: Dynamic Analysis and Design 
Step-by-Step Solution 

1. Unlock the Model 

 
 

Step 1-1: This model is locked automatically after the analysis process is com-
pleted. To unlock this model, click on , a message window prompts with a mes-
sage that ‘all analysis results will be deleted if the model is unlocked’. 

 

2. Define Response Spectrum Function 

 
 

Step 2-1: Click on  or go to Define > Response Spectrum Functions, select 
“Add UBC97 Spectrum” from drop-down menu. 
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Step 2-2: Accept built-in “UBC97” response spectrum by clicking OK. 

 

 
Step 2-3: “FUNC1” response spectrum function has been defined already, click OK 
to end this step. 
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3. Define Response Spectrum Cases 
 

 
Step 3-1: Select working unit to be “in”, go to Define > Response Spectrum 
Cases and click on Add New Spectrum. 

 

 
 

Step 3-2: Specify response spectrum case data as shown in above figure and click 
OK. 
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Step 3-3: “SPEC1” response spectrum function has been defined already in list, 
click OK to end this step. 

4. Run Analysis 

 
Step 4-1: Go to Analysis > Set Analysis Options and click on Set Dynamic Pa-
rameters. 

 

 
Step 4-2: Enter Number of Modes = “20” and click OK 2 times. 
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Step 4-3: Click on  or go to Analysis > Run Analysis, click on Run from Analysis 
Options "Window" and wait until ETABS displays "ANALYSIS COMPLETE" and 
click OK. 

5. View dynamic analysis results 
2 main types of dynamic analysis results can be displayed, first the mode 
shapes and second the member forces/stresses. 

 

Step 5-1: Click on  or go to Display > Show Mode Shape, select Mode Number 
and click OK. 

 

 
Step 5-2: Mode shape can be displayed in animation by clicking Start Animation. 
Click on  to change back to normal mode. 
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Step 5-3: Same as static analysis results, axial force, shear, moment or torsion can 
be displayed by clicking on  and selecting “SPEC1 Spectra”. Click OK. 

 

6. Design Concrete Frame 
 

 
Step 6-1: Go to Design > Concrete Frame Design > Select Design Combo. 
ETABS has defined load combination for every load cases automatically as shown 
in Design Combos list. Load combinations details can be displayed by selecting 
one of them and clicking on Show. 
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Step 6-2: Scale Factor for each load cases has been defined automatically by 
ETABS. Click on OK 2 times and click on  to start concrete frame design. 
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Part C: Design of Shear Wall 
Step-by-Step Solution 

Problem 
Add shear wall (12” thick.) to the model between grid line 2 and 3 along grid 
line A and D as shown in the following figures. Door openings on the wall 
are provided only at the first floor level. 

3D View of the building 

 

Plan and Elevation View 
Plan View at Roof Foor 
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Elevation At Grid Lines 2, 3, 4, B and C 

 

Elevation at Grid Line 1 
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Elevation at Grid Line A 
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Elevation at Grid Line D 

Typical Shear Wall Design Procedure 
Following is a typical shear wall design process that might occur for a new 
building. Note that the sequence of steps you may take in any particular 
design may vary from this but the basic process will be essentially the 
same. 

1. Use the Options menu > Preferences > Shear Wall Design command 
to review the shear wall design preferences and revise them if neces-
sary. Note that there are default values provided for all shear wall de-
sign preferences so it is not actually necessary for you to define any 
preferences unless you want to change some of the default preference 
values. 

2. Create the building model. See the section titled "Modeling Process" in 
Chapter 6 for more information. 

3. Run the building analysis using the Analyze menu > Run Analysis 
command. 

4. Assign the wall pier and wall spandrel labels. Use the Assign menu > 
Frame/Line > Pier Label, the Assign menu > Shell/Area > Pier La-

C1

B1 B1

12
'

12
'

12
'

12
'

12
'

Story 1

Story 2

Story 3

Story 4

Story 5

Base

20'20'

B1 B1

B1 B1

B1 B1

B1 B1

C1

C1

C1

C1

C1

C1

C1

C1

C1

C1

C1

C1

C1

C1



ETABS Tutorial Example ACECOMS, AIT  
 

Static, Dynamic Analysis and Design of Building with Shear Wall 44/ 58 

bel, the Assign menu > Frame/Line > Spandrel Label, and the As-
sign menu > Shell/Area > Spandrel Label commands to do this. 

Note that the labels can be assigned before or after the analysis is run. 

5. Assign shear wall overwrites, if needed, using the Design menu > Shear 
Wall Design > View/Revise Pier Overwrites and the Design menu > 
Shear Wall Design > View/Revise Spandrel Overwrites commands. Note 
that you must select piers or spandrels first before using these commands. 
Also note that there are default values provided for all pier and spandrel 
design overwrites so it is not actually necessary for you to define any over-
writes unless you want to change some of the default overwrite values. 

Note that the overwrites can be assigned before or after the analysis is run. 

Important note about selecting piers and spandrels: You can select a pier or spandrel 
simply by selecting any line or area object that is part of the pier or spandrel. 

6. If you want to use any design load combinations other than the default ones 
created by ETABS for your shear wall design then click the Design menu > 
Shear Wall Design > Select Design Combo command. Note that you 
must have already created your own design combos by clicking the Define 
menu > Load Combinations command. 

7. Click the Design menu > Shear Wall Design > Start Design/Check of 
Structure command to run the shear wall design. 

8. Review the shear wall design results. To do this you might do one of the fol-
lowing: 

1. Click the Design menu > Shear Wall Design > Display 
Design Info command to display design information on the 
model. 

2. Right click on a pier or spandrel while the design results are 
displayed on it to enter the interactive wall design mode. 
Note that while you are in this mode you can revise over-
writes and immediately see the new design results. 

If you are not currently displaying design results you can click the Design menu > 
Shear Wall Design > Interactive Wall Design command and then right click a pier or 
spandrel to enter the interactive design mode for that element. 

1. Use the File menu > Print Tables > Shear Wall Design command to 
print shear wall design data. If you select a few piers or spandrels be-
fore using this command then data is printed only for the selected ele-
ments. 

2. If desired, revise the wall pier and/or spandrel overwrites, rerun the 
shear wall design, and review the results again. Repeat this step as 
many times as needed. 

3. If desired, create wall pier check sections with user-defined (actual) re-
inforcing specified for the wall piers using the Section Designer utility. 
Use the Design menu > Shear Wall Design > Define Pier Sections 
for Checking command to define the sections in Section Designer. Be 
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sure to indicate that the reinforcing is to be checked. Use the Design 
menu > Shear Wall Design > Assign Pier Sections for Checking 
command to assign these sections to the piers. Rerun the design and 
verify that the actual flexural reinforcing provided is adequate. 

4. Assign these check sections to the piers, change the pier mode from 
Design to Check, and rerun the design. Verify that the actual flexural re-
inforcing provided is adequate. 

5. If necessary, revise the geometry or reinforcing and rerun the design. 

6. Print or display selected shear wall design results if desired. 

Note that shear wall design is performed as an iterative process. You can 
change your wall design dimensions and reinforcing during the design 
process without rerunning the analysis. However, you always want to be 
sure that your final design is based on analysis properties (wall dimensions) 
that are consistent with your design (actual) wall dimensions. 

Define Wall Section 
 

 
Step 1-1: Click on   or go to Define > Wall/Slab/Deck Sections, select "WALL1" 
and click on Modify/Show Section. 
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Step 1-2: Accept the defaults by clicking OK to 2 times. 

 
 

7. Draw Wall Sections 
Columns and beams around wall areas will be deleted before drawing the 
wall sections. 

 

Step 2-1: Change "Plan View" window to "STORY5" and select "Similar Stories". To 
delete all frame objects between grid line 2 and 3 along grid line A and D, draw se-
lection rectangular to cover these areas and press Delete on the keyboard  
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Step 2-2: To assign Wall in "Plan View", select , select Property = "WALL1" and 
click on 2 bays. Walls will be added to all stories as shown in "3D View" window. 

  
 

8. Define Reference Planes and Lines 
Reference planes and lines are required to define additional working planes 
other than the real floors (stories). These are useful to define openings, 
staircases, ramps etc. This is similar to defining additional grid lines be-
tween the real floors. In this example these features will be used to create 
door openings on the wall.  

 
Step 3-1: Reference plane will be defined to at the top and bottom of door opening. 
Go to Edit > Edit Reference Planes, Enter "8 ft" (vertical location of the reference 
plane), click Add and click OK. 
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Step 3-2: Reference lines are required at the left and right side of the door opening. 
Go to Edit > Edit Reference Lines, Enter X and Y coordinate as shown in above 
figure, click Add twice and click OK. 

9. Add Wall Opening 
Walls on 1st floor along grid line A will be meshed by using reference plan 
and lines that have been defined in the previous step. The area object 
(wall) at the door opening will be deleted.  

 
Step 4-1: Change "Plan View" to "Elevation View" by clicking on  and selecting 
"A" from "Set Elevation View" window. Draw selection rectangular to cover all walls 
in this "Elevation View". 
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Step 4-2: Go to Edit > Mesh Areas, select "Mesh Quads/Triangles at" and select 
"Intersections with Visible Grids". 

 

 
Step 4-3: All walls on this side are meshed based on reference plane and line, click 
on wall at door opening area and press Delete on the keyboard. 
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10. Assign Piers Labels 
Piers labels are essential for the analysis and design of shear walls. 

 
Step 5-1: Select all wall sections, go to Select > by Wall/Slab/Deck Sections, se-
lect "Wall1" and click OK.  

 

 
Step 5-2: Go to Assign > Shell /Area > Pier label, Select "P1" and click OK.  
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11. Assign Spandrels Labels 
Similar to the piers spandrels labels are required by ETABS for proper 
analysis and design of shear walls. Normally they are provided over the 
openings. 

 
Step 6-1: Click on wall at the top of door opening. Go to Assign > Shell /Area > 
Spandrel label. 

 

 
Step 6-2: Select "S1" and click OK. 
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Step 6-3: Wall over the door opening is labeled as "P1" and spandrel ("S1"). 

 

12. Run Analysis 
Analysis option has been setup for dynamic analysis from Part B already. 
Rerun the problem. 

 

 
 

Step 7-1: Click on  or go to Analysis > Run Analysis, click on Run from Analysis 
Options "Window" and wait until ETABS displays "ANALYSIS COMPLETE" and 
click OK. 
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13. View Shear Wall Results 

 
Step 8-1: Click on  or go to Display > Show Member Forces/Stresses Diagram 
> Shell Stresses Forces, select result parameter and click OK. 

 

 
Step 8-2: Stresses or forces are displayed as color contours, click the right mouse 
on any one of these walls. “Area Diagram” at that wall will be displayed. Move the 
cursor over this diagram to check the value at desired location. Click X at the top-
right of this window to close this “Area Diagram”. 
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14. Design Shear Walls 

 
 

Step 9-1: To select design code, go to Options > Preferences > Shear Wall De-
sign menu, select "UBC97" and click OK. 

 
 
  

    
 

Step 9-2: To see load combination for design, go to Design > Concrete Frame 
Design > Design Combo. 2 load combinations are defined and selected for design 
automatically, select "DCON2" and click Show. Load factors have been defined for 
to comply with the selected code. Click OK 2 times. 
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Step 9-3: Click on  or Design > Shear Wall Design > Start Design/Check 
Structure. After shear wall design is over, ETABS will display “Pier Reinforcing Ra-
tios” as active window. 

 

 
Step 9-4: Right mouse click on any wall to open pier section design details, click 
OK to close this window. 
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Reinforcement Location for Pier 
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Step 9-5:  Spandrel design details or any shear wall design input and/or output in-
formation can be displayed from Design > Shear Wall Design > Display Design 
Info. 

 

Reinforcement Location for Spandrel 
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Note: Typical Detailing of Shear Wall 

 
 


